注册工件

注册待抓工件

有工件模型

如果已有工件的STL模型,可导入模型以注册工件。

  1. 在 运动 页签下快捷工具栏,单击 工件,选择 注册工件。

  2. 单击界面左下角 工件 节点,单击右侧参数设置栏 碰撞模型 下方 添加,选择 模型文件,单击 browse,选择STL模型路径。

    提示

    如果将 可视化和碰撞模型一致 设置为 “否”,则需分别设置碰撞模型和可视化模型。

  3. 查看模型基本信息,为不影响后续计算,如果模型三角面数大于1000,建议先使用模型编辑器,将三角面数减至1000以下。

    1. 单击 edit3,确认模型信息,单击 OK。

      提示

      也可在顶部工具栏,选择 “工具 > 模型编辑器”,打开模型编辑器后导入模型。

    2. 在 Max模型编辑器 窗口顶部工具栏,选择 “编辑 > 模型简化”,选择 “减少三角面”,输入三角面数量后,单击 确认,三角面数会减少至设置的数量。

    3. 在 Max模型编辑器 窗口顶部工具栏,选择 “文件 > 保存”。回到 工件 页签下,导入简化后的模型。

      ../../_images/model_edit2.png
  4. (可选)单击右侧参数设置栏 碰撞模型 下方 添加,选择 长方体、圆柱体、球体,在STL模型基础上添加碰撞体。添加后,设置每个碰撞体的尺寸和位姿。

  5. 单击界面右下角 完成。

无工件模型

如无工件的STL模型,可用碰撞体拼接工件。

  1. 在 运动 页签下快捷工具栏,单击 工件,选择 注册工件。

  2. 单击界面左下角 工件 节点,单击右侧参数设置栏 碰撞模型 下方 添加,选择 长方体、圆柱体、球体,添加一个或多个碰撞体。

  3. 设置每个碰撞体的尺寸和位姿。

    提示

    如果将 可视化和碰撞模型一致 设置为 “否”,则需分别设置碰撞模型和可视化模型。

../../_images/object2.png
  1. 单击界面右下角 完成。

注册箱子

注册箱子模型,一般用于料箱拆码垛场景。

  1. 在 运动 页签下快捷工具栏,单击 工件,选择 注册箱子。

  2. 单击界面左下角 箱子 节点,在右侧参数设置栏设置箱子的尺寸、条码位置等参数。

  3. 单击界面右下角 完成。